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What is CodePrint?

CodePrint ä is a Windows 3.1 compatible program for printing ASCII text files on any printer 
supported by Windows. What makes CodePrint unique is you have control over how the text 
is formatted on the page. You can open and save configurations that allow you to set page 
formatting for the various text files that you normally print. For example, if you are a 
programmer you can set a configuration for printing your source code two-up on a page. You
can also have a configuration for printing README files or ON-LINE service listings. Features 
include:

· Portrait or Landscape paper orientation
· Multiple columns
· Include headers and/or footers that you define including

filename, date and page number
· Change fonts, style and size
· Include border with column dividers
· Change left, top, right and bottom margin
· Change the spacing used to expand tabs
· Text automatically wraps if wider than column
· Open and save page setups
· Compatible with Windows 3.1 Drag-Drop feature using File Manager

The Drag-Drop feature under Windows 3.1 allows you to select files from the File Manager 
and Drag and then Drop them over the CodePrint icon for printing.



Benefits of Registering

CodePrint is distributed as shareware and you must therefore register the software if you 
continue to use the program beyond the 21 day evaluation period. When you register 
CodePrint you will receive the following benefits.

· Latest version of the software on disk
· On-line support from Compuserve or written support by mail
· Notification of low-cost upgrades
· Registration information to remove info screen during program start-up

If you use CodePrint print, please register by filling out the registration form and sending in 
your registration fee.



File Menu

The File menu includes commands that allow you to open and save page configurations, 
change printer settings and exit CodePrint.

For more information, select the File menu command.

Open Configuration Open the DEFAULTS or user saved configurations.
Save Configuration Save the current configuration.
Printer Setup Change printer settings.
Exit Exit CodePrint.



Page Menu

The Page menu includes commands that allow you to change the current font, header and 
footer text and page layout options.

For more information, select the Page menu command.

Font Change font.
Header/FooterChange header and footer text.
Layout Change page layout.



Help Menu

The Help menu includes commands that allow you to display help for various topics related 
to CodePrint.

For more information, select the Help menu command name.

Contents
Search
About CodePrint



List Command

The List push button on the main CodePrint window is used to populate the file list box with 
files in the current directory that match the wild card specification in the File spec. edit 
control. Therefore, if a file name is entered or displayed in this field, by selecting a file name 
from the file list box, the List push button is disabled.



Select File(s) Command

The Select push button on the main CodePrint window is used to populate the print list box 
with the selection in the File spec. edit control. If the file spec. control contains a file name, 
the file name will be displayed in the print list box. If the file spec. control contains a wild 
card specification such as *.txt, all the files in the current directory that match the file spec. 
are displayed in the print list box. If the file spec. edit control is blank, the Select push button
is disabled.



Print File(s) Command

The Print Files push button on the main CodePrint window is used to print the all the files 
listed in the print list box located directly under the button. If the print list box is empty, this 
button is disabled.



Remove Command

The Remove push button on the main CodePrint window is used to delete the file entry 
selected in the print list box. If the print list box is empty, this button is disabled.



Clear All Command

The Clear All push button on the main CodePrint window is used to delete all the file entries 
displayed in the print list box. If the print list box is empty, this button is disabled.



Opening a Configuration

To change the current configuration, select Open from the File menu to display the Open 
Configuration dialog. The first configuration is always the DEFAULTS as shipped. Other saved 
configurations are listed below the DEFAULTS configuration.

To load a configuration, highlight the configuration you want to open and press OK or 
alternately double-click using the left mouse button. The selected configuration is now the 
current one with the configuration name displayed in the caption bar.



Saving a Configuration

To save the current configuration, select Save from the File menu to display the Save 
Configuration dialog. The current configuration name is displayed in the edit control.

To save the current configuration under the current name, press OK. To save the current 
configuration under a new name, type the new configuration name and press OK.

The following information is saved for each configuration.

· Page specific - number of columns, margins, spacing for tabs, border and orientation
· Font specific - size, style and type face
· Header specific - header text
· Footer specific - footer text
· General - file spec., directory path and window position



Changing Printer Setup

To change various printer options such as orientation or paper tray option, select Printer 
Setup from the File menu. If you only want to change the paper orientation, select the 
Layout command from the Page menu to change this feature.



Changing Fonts

To change the font, select Fonts from the Page menu to display the Font dialog. This is the 
font common dialog new to Windows 3.1.

Changing font, style or size affects both the page text and the header/footer text.



Changing Header/Footer

To change the header and/or footer text, select Header/Footer from the Page menu to display
the Header/Footer dialog. You can enter any text you want for either the header or footer. To 
access the file name, date/time or the page number you can press the appropriate push 
button along the bottom of the dialog, which will insert the formatting characters at the 
location of the I-beam cursor. For example, the following footer

c:\files\readme\readme.txt - page 1

would be displayed as follows in the footer edit control.

%f - page %p

Where %f inserts the file name and %p inserts the current page number.

For the header or footer to be printed, the header and footer check boxes must be checked. 
The middle and right status fields, located below Columns, displays the current status of the 
header and footer respectively. If "On" is displayed, the option is ON, while "Off" means 
disabled.



Changing Page Layout

To change the page layout options, select Layout from the Page menu to display the page 
layout dialog. From the page layout dialog you can change or toggle the following page 
features.

· Number of text columns per page
· The number of spacing used to expand tabs
· The amount, in inches, for the left, top, right and bottom margins
· Page with border and column dividers or no border
· The page orientation which can be landscape or portrait

The status of the border is displayed in the left most field below Columns. If "On" is 
displayed the border option is ON, while "Off" indicates borders are disabled.



Drag and Drop Printing

CodePrint takes advantage of the new Drag-and-Drop feature of Windows 3.1. CodePrint can 
be iconized or opened to use Drag-and-Drop. However, it is more convenient to use the 
drag-drop feature when CodePrint is iconized. To use the drag-drop feature, open File 
Manager and select the text file(s) you want to print. Then drag the files over the CodePrint 
icon or within the CodePrint window and release the mouse button.



Using the Toolbar

The toolbar, displayed below the menu bar, provides quick access to various commands.

Opens a configuration file.

Saves the current configuration.

Displays the font dialog.

Displays the header/footer dialog.

Displays the page layout dialog.

The two status fields to the right of the buttons display the size, in bytes, and the date last 
modified for the file selected in the file list box. Initially these fields are blank and will not 
display until a file is selected in the file list box.



Glossary

configuration
DEFAULTS
edit control



Open Configuration Command

Use this command to change the current configuration Select Open from the File menu to 
display the Open Configuration dialog. The first configuration is always DEFAULTS as 
shipped. Other saved configurations are listed below the DEFAULTS configuration.

To load a configuration, highlight the configuration you want to open and press OK. The new  
current configuration is displayed in the caption bar.



Save Configuration Command

Use this command to save the current configuration Select Save from the File menu to 
display the Save Configuration dialog. To save the current using the current configuration 
name press OK. To save under a new name, enter the name and press OK to save the 
configuration under the new name.

The following information is saved for each configuration.

· Page specific - number of columns, margin, border and orientation
· Font specific - size, style and type face
· Header specific - header text
· Footer specific - footer text
· General - file spec. and directory path



Printer Setup Command

Use this command to change various printer options. Select Printer Setup from the File menu
to display the Printer Setup dialog. You can change printer options such as orientation and 
paper tray.



Exit Command

Select Exit to close CodePrint.



Font Command

Use this command to change the current font used for printing. Select Font from the Page 
menu to display the Font dialog. Changing the font, style or size changes both the page text 
and the header and footer text.



Header/Footer Command

Use this command to change the header and/or footer text. Select Header/Footer from the 
Page menu to display the Header/Footer dialog. You have the option to include or not include
header and footer text. You can enter any text and optionally include format codes to insert 
the File Name, Date/Time or Page number in the header or footer.



Page Layout Command

Use this command to change the page layout options. Select Layout from the Page menu to 
display the Page Layout dialog. From the Page Layout dialog you can change number of 
columns on a page, the number of spaces used to expand tabs,    toggle printing without or 
with a border with column dividers, change paper orientation, and change the left, top, right 
and bottom margin.



Help Contents Command

Use this command to display the help index for CodePrint.



Help Search Command

Use this command to display the help search dialog for locating specific help topics. 



Help About CodePrint Command

Use this command to display the about dialog for CodePrint. This dialog contains copyright 
information, version number, current Windows mode and Windows resource information.



Page Layout Dialog

The Page Layout dialog allows you to change the number of columns on a page, the number 
of spaces used to expand tabs,    toggle printing without or with a border with column 
dividers, change paper orientation, and change the left, top, right and bottom margin.

The following chart list the DEFAULTS settings.

Column
s

Tab Border Orientatio
n

Left Top Right Botto
m

1 8 OFF PORTRAIT 0.05" 0.05" 0.05" 0.05"

If you are using a dot matrix printer and the right or bottom margin is off the page, you may 
want to change the margins as follows.

Left Top Right Botto
m

0.10" 0.30" 0.10" 0.30"

You may have to experiment to find the margin settings that work correctly with your printer.





Contents

 The Contents contains a list of all Help topics available for CodePrint. For information on 
how to use Help, press F1 or choose Using Help from the Help menu.



Configuration

A configuration stores program options. You can therefore change settings such as the font 
and font size and save configurations under various names. The default configuration is 
always available if you want to load the application defaults.



Default

The DEFAULTS configuration retains the settings as shipped.



Edit Control

A edit control is a field for retrieving information from the user that is required by the 
application program.






